Yoast SEO 19.5 update causes fatal errors


Publishers who updated to Yoast SEO 19.5 may have experienced more than expected. Reports of fatal errors caused by the update soon began to surface. Interestingly, the error seems confined to specific situations and not at all levels.

Yoast SEO version 19.5

Yoast version 19.5 contains several changes that improve the user experience, fix a validation issue in the article structured data, and fix some minor bugs.

A notable improvement is the front-end SEO inspector which provides an overview of posts and various SEO settings such as meta tags and structured data.

Unfortunately, a bug also occurred in a specific situation that caused a fatal error.

A fatal error can occur when there is a conflict between two plugins.

yeast fatal error

Eli Schwartz, search marketing expert and author of the popular book Product Led SEO, tweeted about a fatal error.

It is not uncommon for a random conflict between plugins to cause problems. But it wasn’t so random, as others confirmed the same thing happened to them.

Yoast SEO’s official support page on WordPress.org also had reports of fatal errors.

A user posted:

Fatal error: YoastSEO_Vendor not caught

“I woke up today and tried to access my website dashboard and got a fatal error, I can’t access it through the backend or login.
How can I solve this problem.

Two others replied with the same issue, one of them offering this comment:

“Same here. Unable to connect to backend and both site and backend throw a fatal error.

I saw that Yoast updated automatically today.

Moved the free version and the premium version of the plugins directory to a temporary directory and now the site is back online.

Someone else with the same free and premium version setup echoed this report, posting:

“Getting fatal error after update too. Also have free version, premium version and News SEO.”

The official Yoast support manager apologized and responded with this statement:

“We’re sorry you encountered a fatal error. Thanks for reporting.

We are investigating and there seems to be an issue with the latest Yoast SEO update while the most recent Premium has not yet been released. It shouldn’t have happened.

We are looking to fix this issue as soon as possible by releasing a fix for free and also releasing Yoast SEO Premium as soon as possible.

Either should fix the fatal error.

Yoast responds

Joost de Valk, the founder of Yoast, provided his comments to Search Engine Journal:

“A patch was created quickly by the team indeed and for most sites that fully resolved it.

For some sites, the auto-update mechanism didn’t work properly, and as a result, those sites didn’t auto-correct.

We discussed it a lot internally, because we weren’t happy at all that it happened, and we weren’t happy with the way we handled it. Honestly, we’re all really disappointed and sorry for the sites we broke.

Yoast identifies the problem

The last commenter who noted that they had two versions of the Yoast plugin installed, the free and premium versions, may have been a clue as to what caused the fatal flaw, as this situation was cited as the reason why the fatal error occurred.

Yoast responded quickly to the issues and released a same-day patch, version 19.5.1.

According to the Yoast SEO WordPress plugin changelog which documents the contents of each update:

“19.5.1 – Bug fixes:

Fixes a bug where a fatal error was generated on the front-end when Yoast SEO 19.5 was used with an older version of Yoast SEO Premium.

The problem is solved with version 19.5.1

Yoast 19.5.1 fixed the issue.

A user posted this comment on the Yoast support forum:

“Update 19.5.1 fixed the issue.”

However, since there are millions of users with millions of combinations of other plugins installed, it is almost inevitable that very few edge cases will arise with issues.

For example, in a Yoast official support forum post, a user describes updating from 19.4 directly to 19.5.1 and not having a satisfying experience.

They shared:

“I went from 19.4 to 19.5.1 and it still broke my site. I don’t think .5.1 solved the whole problem. I never updated to 19.5. Going straight from 19.4 to 19.5. 1.
I have yoast, premium yoast and woo. all 3. First, the one to try to update was the regular yoast. All other plugins and WP on my site are up to date. Hope this helps fix 19.5.1

Glad never to trust auto-update, I’m not a fan of paying someone to be a beta tester.

Still, this one always got me.

It is not unusual for edge cases to appear for any update, and this could be the case for Yoast 19.5.1.

The cause of the problem seems to be that Yoast released an update for the free version of Yoast (19.5) but did not simultaneously release an update for the premium version, which then caused a conflict between the two plugins , resulting in a fatal error.


Featured image by Shutterstock/Kues


Add Comment